NoMachine Support

Your questions answered

Knowledge Base

Searching in: Articles & FAQs
Filter the search results
Applies to:
Last update:
Searching in: Articles & FAQs
ID: AR07H00568
Applies to: FAQs
Added on: 2010-07-20
Last update: 2019-02-06
Which operating systems are supported?

NoMachine's commitment has always been to provide packages for the widest range of most frequently used platforms and operating systems. NoMachine software runs on Mac OS X, Windows and Linux operating systems, the minimum required versions are: 

  • Mac OS X 10.7
  • Windows XP
  • Red Hat Enterprise 4.4
  • SLED/SLES 10.x
  • Open SUSE 10.x
  • Fedora 10
  • Debian GNU Linux 4.0 Etch
  • Ubuntu 8.04 Hardy Heron
  • Raspberry Pi 2/3 ARMv6/ARMv7/ARMv8

 

For a complete list of platforms supported by the current version of NoMachine products, please refer to the download page of each product.

Rest assured that the NoMachine development team will continue to work hard to add support for further environments and/or processor architectures in the future; and will take into account the latest versions of  the supported operating systems as per support policies already in place.

In general NoMachine should work with the latest version of the Operating System, unless major changes in the OS require NoMachine to align its own software. In that case, a period of at least 30 days is generally required to ensure full compatibility.  You might also be interested at NoMachine policies to support pre-release versions of operating systems:

www.nomachine.com/AR03E00450

 

Regarding earlier versions of Operating Systems, in order to ensure a consistently high quality remote access software across the most popular platforms, as well as because of some technical considerations related to the evolution of NX software, the following OS versions are no longer supported since NoMachine v. 4:

  • RedHat 7.2/7.3/8.0/9.0/RHEL 3.0/4.0/4.1/4.2/4.3
  • SuSE Linux 7.2/7.3/8.0/8.1/8.2/9.0/9.1/9.2/9.3
  • Mandriva Linux 9.0/9.1/9.2/10.0
  • Fedora Core 1/2
  • Debian GNU/Linux 3.0 Woody/ 3.1 Sarge
  • Ubuntu 5.04 Hoary
  • Xandros 3.0
  • Mac OSX 10.3/10.4
  • Solaris SPARC 8/9 or later