Support Center

Your questions answered

Knowledge Base

Searching in: Articles & FAQs
Filter the search results
Applies to:
Last update:
Searching in: Articles & FAQs
ID: AR11D00430
Applies to: NX Licensing
Added on: 2006-11-28
Last update: 2013-10-08
Receiving the message "Your evaluation period has expired" or "WARNING: Sorry, your upgrade period has expired" in 3.5.0

The NX Server upgrade procedure is not designed to update the original node.lic and server.lic files provided by a a previous installation, but the default behavior is to preserve them instead.

This means that, if you had previously installed any of the NX Server evaluation versions and then you have upgraded to the Free Edition or perhaps a subscription, your software still is an evaluation version which has an evaluation period of 30 days. Similarly, if you installed NX Free Edition and then install NX Server Evaluation without completely removing NX Free Edition, the license files from NX FE will interfere with e.g. NX Enterprise Server.

You can verify this by checking the version of your NX node and NX server:

# /usr/NX/bin/nxnode --version

# /usr/NX/bin/nxserver --version

For example, if you upgrade your evaluation version to the Free Edition during the 30 days of the evaluation period, once this period expires, your NX server will stop working and will display the following message at every attempt to start a session:

NX> 618 Your evaluation period has expired. Please visit
NX> 618 the NoMachine Web site at http://www.nomachine.com/
NX> 618 to acquire a valid subscription.

If you try to check the NX node and NX server version, you will
get this message:

# /usr/NX/bin/nxserver --version
NX> 618 Your evaluation period has expired. Please visit
NX> 618 the NoMachine Web site at http://www.nomachine.com/
NX> 618 to acquire a valid subscription.
NX> 999 Bye.

# /usr/NX/bin/nxnode --version
NX> 618 Your evaluation period has expired. Please visit
NX> 618 the NoMachine Web site at http://www.nomachine.com/
NX> 618 to acquire a valid subscription.
NX> 999 Bye.

NOTE: If you try to upgrade your evaluation version to the Free Edition after the evaluation period has expired, you will get the following message during the upgrade procedure:

NX> 701 WARNING: Sorry, your upgrade period has expired. To be able to
NX> 701 WARNING: install a new version of the software, please visit the
NX> 701 WARNING: NoMachine Web site at http://www.nomachine.com/
NX> 701 WARNING: yo acquire a valid subscription.

What should I do to run the correct version of the NX Server?

You will need to completely uninstall your previous installation (this includes not just nxserver and nxnode, but also nxclient).  It would also be a good idea to make a backup first. Then, you will need to remove the /usr/NX/ directory and then install NX from scratch, using your choice of server packages.

For example, rpm -e nxserver nxnode nxclient to remove the packages, then rm -rf /usr/NX to remove the directory.

If you want to verify that your installation is the free-forever version, you may check the subscription files by running:

# cat /usr/NX/etc/server.lic | grep 'Expiry'
Expiry:             Unlimited

# cat /usr/NX/etc/node.lic | grep 'Expiry'
Expiry:             Unlimited

Also, checking the NX node and NX server version, you should have
an output similar to:

# /usr/NX/bin/nxserver --version
NXSERVER - Version 2.1.0-13 - LFE

# /usr/NX/bin/nxnode  --version
NXNODE - Version 2.1.0-12 - LFEN