NoMachine Support

Your questions answered

Knowledge Base

Searching in: Feature Requests
Filter the search results
Target version:
Products:
Status:
Last update:
Searching in: Feature Requests
ID: FR05Q03833
Added on:  2019-05-06
Last update: 2020-11-16
Priority: Low
Products: NoMachine Server
Target: 7
Status:  Approved
Upgrading libssh2 to the newest available version of libssh2

The libssh2 library shipped with the NoMachine packages and used for connections by SSH protocol, should be upgraded to libssh2 v. 1.8.2 (March 25th 2019) or to a newest version if available in the meantime. Ref. https://www.libssh2.org/

NoMachine packages v. 6 ship libssh2 1.7.0.

Upgrading to libssh2 v. 1.8.2 will also allow to add support for RSA keys in the new OpenSSH format, see https://www.nomachine.com/FR05Q03834.


Notify me when the FR is implemented.