NoMachine Support

Your questions answered

Knowledge Base

Searching in: Trouble Reports
Filter the search results
Last update:
Affects:
Product:
Status:
Searching in: Trouble Reports
ID: TR04Q09255
Added on: 2019-04-24
Last update: 2019-04-24
Affects: 6
Due to be solved in: 6
Platform: All Linux Platforms
Product: NoMachine Server
Severity: Minor
Status: Open
Packages v. 6 obsolete packages v. 5 when stored in an internal RPM repository

In some cases, customers may need to store NoMachine packages in their own repository. If nomachine-workstation and nomachine-terminal-server-node are all stored together in a RPM repository, when upgrading the installation of nomachine-workstation v.5, yum shows that nomachine-terminal-server-node obsoletes this package.

This behavior is triggered bychanges in product functionalities introduced in v. 6.
In v. 5, NoMachine Workstation was either a standalone server or a node of a multinode server. In v. 6, the Workstation can be only a standalone server. A multinode environment requires to convert the Workstation v. 5 into a Terminal Server Node v. 6.

Specifying the version of the Workstation packages in the node rpm file should solve this issue.

In node rpm file set:

Obsoletes: nomachine-workstation < 6


Notify me when the TR is closed.